EcoSend - Services unavailable – Incident details

All systems operational

Services unavailable

Resolved
Major outage
Started 14 days agoLasted about 3 hours

Affected

Email Sending

Major outage from 7:28 AM to 9:31 AM, Partial outage from 9:31 AM to 10:17 AM

Forms

Major outage from 7:28 AM to 9:08 AM, Partial outage from 9:08 AM to 9:31 AM, Operational from 9:31 AM to 10:17 AM

App

Major outage from 7:28 AM to 9:08 AM, Operational from 9:08 AM to 10:17 AM

Updates
  • Resolved
    Resolved

    All services operating normally.

  • Update
    Update

    Email sending is returning to normal. We're continuing to monitor

  • Monitoring
    Monitoring

    Some services are recovering. Email sending is still experiencing issues

  • Identified
    Identified

    Out cloud provider is currently experiencing issues causing an outage across all EcoSend services. We're working to mitigate